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About this guide 
The PhoneSoft Unified MailCall Installation Guide contains instructions for installing and setting up Unified MailCall. 
The latest version of this guide can be found at: http://www.phonesoft.com 

The guide focuses on Unified MailCall. For extensive information about the installation, setup and use of third-party 
software and hardware refer to the relevant manufacturer's documentation. 

For information on using Unified MailCall, please refer to the User Guide. 

Documentation conventions 
The guide uses the following conventions:  

User Input 
Information that the user types appears in Courier: edit  

Key names 
Key names appear in capital letters: ENTER.  

Cascading selections 
The ">" symbol separates the selections you make: on menus (Programs>Intel Dialogic System 
Software>Configuration Manager); in the navigation levels of Unified MailCall and in menu trees.  
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Installation overview 
The following steps offer general guidelines for setting up a new version of Unified MailCall. 

Setup steps 
Confirm the minimum system requirements. 

See Minimum system requirements.  

Collect all installation checklist components.  
See Installation checklist. 

Install voice boards. 
See Installing voice boards. 

Set up the phone system integration. 
See Setting up the phone system. 

Install Unified MailCall. 
See Installing and starting Unified MailCall. 

Set up Unified MailCall. 
See Changing default settings, See Setting up users and See Setting up phone lines.  

Install optional Unified MailCall packages. 
See Installing RealSpeak, See Installing additional languages and See Setting up Play By Phone and Play 
Multimedia. 

Customize automated attendant.  
See the PhoneSoft Software Development Kit User Guide for details.  

Using Demo Phone with the trial software 
  

Upgrading from MailCall (E-Mail Reader) to Unified MailCall (Unified Messaging) 

To upgrade from MailCall to the latest version of Unified MailCall, use the Windows Uninstall program to uninstall 
MailCall and then follow the Setup steps above to install Unified MailCall.  

MailCall and Unified MailCall have a few shared settings that may already be set up for E-Mail Reader. When you find 
fields or procedure steps that are already set up or done, you can skip them and go to the next installation step. 
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Installation requirements and checklist 

Minimum system requirements 
• Pentium 4 2GHz (or higher) computer with a CD-ROM drive and monitor. 

• Windows workstation (2000 or XP) or server (2000 or 2003). 

• 512MB of RAM. 

• 300 MB of available hard disk space. 

• Lotus Notes client or Domino server version 6.x or higher software, which is installed and set up on the 
computer.  

• The computer's system path contains the Notes or Domino directory. To confirm and set up the path, see 
To confirm the system path exists. 

• An available PCI computer slot. 

• At least one PCI voice board that corresponds with the available slot. 

• Unified MailCall can be installed on either a Notes client computer or a Domino server. For systems 
with:  

• Less than 16 ports, you can run Unified MailCall on the same computer as the Domino server that 
stores the applicable databases.  

• 16 or more ports, run Unified MailCall on a separate dedicated Notes client computer that is 
connected to the applicable Domino server. 

Note: Additional memory may increase performance. If you are running other applications 
on the same computer, 1 GB of RAM may be needed. 

Installation checklist 
• Computer that meets the minimum system requirements. 

• Unified MailCall software and documentation available on our web site at www.phonesoft.com or via 
CD. 

• License file that you receive from your sales representative. This file is not available on our web site.  

• Password that you receive from your sales representative. 

To confirm the system path exists 

1. At a DOS prompt on the Unified MailCall computer, type notes and press ENTER. 

If Notes or Domino start, the path exists. If Notes or Domino does not start, perform one of the following three 
procedures, as appropriate. 

To set up the computer's system path for Windows 2000/XP/2003 

1. From the Start menu on the Unified MailCall computer, select Settings>Control Panel and then double-
click "System". 

2. Click "Advanced" and then click "Environment variables".  

3. In the System Variables box, locate and select the path and then click "Edit". 

4. At the end of the current path, type a semicolon (;) and the Notes or Domino directory path. 
For example: %systemroot%system32%systemroot%;C:\Lotus\Notes 

5. Click "OK" and close the dialog box.  
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6. Confirm the path is set correctly by repeating the "To confirm the system path exists" procedure above. 
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Installing voice boards 
 

Unified MailCall requires a voice board, which is a phone interface card, to physically connect phone lines or 
extensions from the phone system (or the phone company's system) to the Unified MailCall system.  

Before installing Unified MailCall, install and set up the voice boards. All Dialogic voice boards are shipped with 
installation and setup instructions. 

The following Dialogic voice boards are supported by PhoneSoft Unified MailCall. 

 

Board Interface Bus 

Dialogic D/4PCI Analog PCI (universal) 

Dialogic D/120JCT Analog PCI (universal) 

Dialogic D/42JCT Digital PBX PCI (universal) 

Dialogic D/82JCT Digital PBX PCI (universal) 

Dialogic D/240JCT-T1 Digital T1 PCI (universal) 

Dialogic D/300JCT-E1 Digital E1 PCI (universal) 

  

Installing a voice board 

1. Attach an antistatic wrist strap. 

2. If you already turned on the computer, shut down the software and then shut down the computer.  

3. Remove the cover from the computer or expansion chassis.  

4. Select an empty PCI slot as appropriate, and remove the slot's retaining screw and access cover plate. 

Note: PCI boards can be put into either 32-bit or 64-bit PCI slots. 

5. Perform the applicable procedures to set the switches and jumpers on each board. Some boards include 
hardware settings that indicate which board is first, which is second, and so on. If you are installing 
more than one board of the same model, keep the boards in order so you can install them in the correct 
order in the next step. 

6. Insert each board firmly into its slot, and fasten each board to the computer's backplane with a screw. If 
you are installing more than one board of the same model, and if the boards include a hardware setting 
that indicates which board is first, second, and so on, install the boards in the order specified by the 
hardware settings. 

7. If you are installing multiple voice boards that have SC or CT bus connectors, cable the boards together. 
On each board, connect the cable so the red stripe on the cable corresponds with pin 1 on the board 
connector. Confirm that the connectors are firmly seated. If the cable has more connectors than the 
computer has voice boards, use the first and last connectors, and leave unused connectors in the middle 
of the cable. If the end of a cable is allowed to dangle loose, it can act as a radio antenna and pick up 
noise from the bus. If you are cabling three or more boards together, connect the first connector on the 
cable to the first board, the second connector to the second board, and so on. 

8. Replace the cover of the computer or expansion chassis. 
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Setting up the voice boards 
 

After installing one of the supported Dialogic voice boards, install the driver software.  

If you purchased the voice boards from PhoneSoft, your voice board package includes a Dialogic System Software disc 
or download link.  

The following procedures are provided as examples of a typical installation and setup. The Dialogic installation 
program provided for your voice boards may be slightly different. For detailed instructions, refer to the voice boards' 
documentation.  

To set up the voice boards, perform the following procedures.  

To test that a board was installed and set up correctly, perform see To diagnose the board(s).  

To install the Dialogic software 

1. Ignore the Windows "Found New Hardware" message for Intel PCI telephony boards. 

2. Insert the Dialogic System Software disc in the Unified MailCall computer's CD-ROM drive. 

3. Go to the disc's directory and double-click the Setup.exe file. 

4. Follow the on-screen instructions and select the Typical Installation option.  

To set up the boards 

1. From the Windows Start menu, select Programs> Intel Dialogic System Software>Configuration 
Manager - DCM.  

2. PCI boards should be automatically detected and added to the list of available.  

3. Click the board that you are installing.  

4. Follow the on-screen instructions to set up the boards.  

5. Note that the Windows "Found New Hardware" message for Intel PCI telephony boards can be 
disabled. It is recommended that the DCM board location process be executed at least once before 
disabling the "Found New Hardware" messages. To disable select "Skip Driver Installation". 

6. After setting up all of the boards, exit the utility. 

To set up the board to automatically start with the computer 

1. From the Windows Start menu, select Programs> Intel Dialogic System Software>Configuration 
Manager - DCM.  

2. Click "Service" and then click "Start Up Mode". 

3. Click "Automatic". 

4. Test Dialogic service startup by pressing the green button "Start Service". 

To install the Intel Dialogic WAV driver files 

1. From the Start menu, choose Settings> Control Panel.  

2. Double-click "Add/Remove Hardware". 

3. From the Add/Remove Hardware Wizard dialog box, click "Next". 

4. Select "Add/Troubleshoot a device" and then click "Next".  

5. Select "Add a new device," then click "Next". 

6. Select "No, I want to select the hardware from a list" and click "Next". 

7. Select "Sound, video and game controllers" and click "Next".  

8. When asked to select a device driver, select "Standard system devices" and then click "Have Disk". 
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9. Go to the directory that contains the Dialogic software and then go to the Lib subdirectory.  

10. Open the Oemsetup.inf file and click "OK". 

11. Confirm that "Dialogic Wave Driver 1.x" is selected and then click "Next". 

12. Select "Hardware Installation" and click "Next". 

13. When the Digital Signature dialog box appears, click "Yes". 

14. If the Files Needed dialog box appears, confirm that the path is set correctly and click "OK". 

15. At the Dialogic Wave Driver Configuration dialog box, click "OK" and then click "Finish". 

16. Restart the computer to update the system. 

To diagnose the board(s) 

1. From the Windows Start menu, select Programs> Intel Dialogic System Software>Universal Dialogic 
Diagnostic Utility.  

2. Click the board that you want to test.  

3. Click "Run Tests". It may take several minutes for these to run. If any errors are reported, resolve them 
before continuing with the Unified MailCall installation process.  

.  
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Setting up the phone system 

How the integration works 
Phone lines connect the phone system and the Unified MailCall computer. Unified MailCall supports many types of 
analog, DID (Direct Inward Dial), PBX digital extensions and digital T1, E1 phone lines. The voice board installed in 
the Unified MailCall computer must match the lines from the phone system or the phone company's central office.  

The following illustration shows a typical Unified MailCall and phone system integration. 

 
With a typical integration, the phone system may send the following information with forwarded calls: 

• The called party's extension 

• The reason for the forward (the extension is busy, does not answer, or is set to forward all calls) 

• The calling party's extension (for internal calls) 

Unified MailCall uses this information to answer the call appropriately. For example, a call forwarded to Unified 
MailCall is answered with the user's personal greeting. If the phone system routes the call to Unified MailCall without 
this information, Unified MailCall answers with the opening greeting. 

Unified MailCall offers one or more of the following that may take advantage of features found on your phone system.  

Call forward to personal greeting 
When an incoming call is routed to an unanswered or busy extension, the call is forwarded to the user's voice mail. The 
caller then hears the user's personal greeting and can leave a message.  

Easy message access 
If the phone system uses a serial integration (SMDI or MCI), a user can retrieve messages without entering an ID. 
Unified MailCall identifies a user based on the extension from which the call originated. A password may be required.  

Message Waiting Indication (MWI) 
When a message is waiting for a user, Unified MailCall notifies the phone system to activate the message waiting 
indicator on the user's extension. 
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Procedure for setting up the phone system 
The following procedure provides general information about setting up a phone system; refer to your phone system 
documentation for specific information. 

To set up the phone system 

1. Assign extensions for the voice mail ports, which are the lines connecting the phone system and Unified 
MailCall. 

2. If the phone system supports hunt groups, set up the hunting order for the voice mail extensions (port 1 
to port 2, and so on). If the phone system does not support hunt groups, you can simulate a hunt group 
by forwarding each voice mail extension to the next extension in the simulated hunt group on busy. 

3. If the phone system supports hunt group access codes, assign a hunt group access code for the voice 
mail extensions. This code is the number that users dial internally to connect to Unified MailCall. 

4. Program which trunks (if any) will route to the voice mail extensions. 

5. Program the phone system to handle calls when all voice mail ports are busy. Calls may be forwarded to 
an operator, get a busy signal, or get a ringback tone until one of the ports becomes available. 

Testing the setup 
To test that the phone system is set up correctly, perform the following procedure.  

To test the phone system setup 

1. Locate a standard analog phone set with a ringer. If the system uses feature phone sets, use a feature set 
for the test. 

2. If the voice boards use RJ-14 connectors, locate a line splitter to separate the two extensions carried by 
each phone line. 

3. Connect the test phone set to the phone system by using a line designated as a voice mail extension. 

4. Confirm that the phone system identifies DTMF (dual tone multiple frequency) tones to the test 
extension. Do this by dialing a station phone from the test phone. Have someone answer the station 
phone and dial a number. You should hear the tone on the test phone. Repeat this test for each type of 
station connected to the phone system (for example, analog or operator). 

5. Confirm that the test phone can access outside lines. To do this, dial a number outside of the phone 
system from the test phone. You should reach the outside number. 

6. Confirm that the phone system generates rings on the test extension. To do this, use a station phone to 
dial the test phone's extension. The test phone should ring.  

7. For phone systems that support trunk routing, check that trunk routing is set up correctly for extensions 
that only answer calls from stations. To do this, dial the test phone's extension from a station phone. 
Answer the test phone and perform a hookflash (timed break recall); then dial a station phone, listen for 
ringing, and disconnect. The call should be transferred to the phone that you dialed.  

Connecting Unified MailCall and the phone system 
After setting up and testing each of the voice mail phone lines on the phone system, you need to connect the two 
systems.  

The type of phone line that you use to connect the two systems, depends on the type of voice boards installed in the 
Unified MailCall computer. Refer to for information about a supported voice board's connectors and port size. 

To connect the phone system to Unified MailCall connect a phone line from each phone system extension to a socket 
on the voice board backplate of the Unified MailCall computer. 
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Installing and starting Unified MailCall  

Installing Unified MailCall  
After setting up the voice boards and the phone system integration, perform the following to install Unified MailCall   

After installation, you can set up Unified MailCall to automatically start when the computer starts. To do this, set up 
Unified MailCall as a Windows Service by performing the second procedure.  

To install Unified MailCall  

1. Locate and open the Unified MailCall “setup_mc.exe” installation file. 

2. Click "Yes" when asked if you want to install the software. 

3. When asked, type the password that you received with the license file and then click "OK". 

Note: The password is case sensitive. 

4. Follow the on-screen instructions to complete the installation. 

5. Copy the Umailcall.lic file into the directory that contains the Phoneserver.exe file. If you received the 
Umailcall.zip file in an e-mail message, copy the file to a temporary directory, unzip it and then copy 
the Umailcall.lic file to the same directory as the Phoneserver.exe file. 

6. Copy the PSNames.NSF database from the installation directory (default C:\PhoneSoft) into your 
Notes-Data directory. 

7. Start PhoneServer.  

To set up a phone line 

1. In the Telephone Line Status Grid, double-click the line that you want to set up. 

 

Note: if the fields are grayed out, then an application may be active on that line. To 
stop activity, click "Stop" and then click "Yes".  

2. In the Line Setup dialog box, go to the "Phone #" field and type the extension number that the phone 
system will use to access this line. 

3. In the Application list, select "Unified MailCall" and click "Start" to start the application.  

4. If you want PhoneServer to automatically run the selected application on this line, select the "Auto 
Start" check box.  

5. Click "Close" to complete the setup.  

6. Repeat this procedure for each phone line. 

Note: when a phone line is set up correctly, the Status Grid displays the application as 
up and running and the Activity displays "Waiting for Call".  
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To set up PhoneServer ID’s Notes password 

1. From PhoneServer’s menu choose “Edit” then “Notes Password…” 

2. Enter Notes password of Notes client or Domino server installed. 

 
Note: This is the password used by the UserID or ServerID installed on the PhoneSoft PC. 

 

To set up SMDI Link 

If your PBX supports serial SMDI integration, enable the link as follows. 

1. From PhoneServer’s menu choose “Edit” then “SMDI Link…”. 

2. Select the COM port where your PBX serial link has been connected. 

3. Select your PBX. 

 

 

Starting PhoneServer 
PhoneServer provides a system administrator interface for setting up and maintaining Unified MailCall and the phone 
system integration. 

You can use PhoneServer to monitor system status and examine system utilization. 

To start PhoneServer 

• From the Start menu, choose the Programs>PhoneSoft>PhoneServer. 

To close PhoneServer 

• Click the File>Exit menus. 

To set up Unified MailCall as a Windows Service 

1. From the Start menu, choose the Run menu. 

2. Type phoneserver -install and click "OK". 

PhoneServer will now be created as a Windows Service and set up to start automatically on Windows startup. 
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Changing default settings 
Before Unified MailCall can answer calls, you need to set up the system.  

The standard installation sets up the system with the common defaults for automated attendant and other system 
options. To modify the standard setup, perform the procedures below. 

To change Unified MailCall default settings 

1. From the PhoneServer menu bar, select the Edit>Configuration menus.  

2. In the PhoneServer Properties dialog box, you can change the settings available in these windows. 

General settings 

 
Names Server:  Domino server where PhoneSoft directory is located (blank if local). 

Names Database: name of PhoneSoft directory (default PSNames.NSF). 

Use local “Mail.box”: check if PhoneSoft is running on Domino server. 

Use multiple “Mail.box”: check if Domino server is using multiple router mailboxes. 

Create Statistics: if checked PhoneSoft will create a statistics document in PSNames.NSF. 

Recording Format: leave default or change to CODEC1k to compress WAV files down to 1k/sec. 

Prompt Format: leave default PCM 8k. 

Max Record Time: maximum length of recorded messages. 

Min Record Time: minimum length of recorded messages. 
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TTS settings (Text-To-Speech) 

 
Choose TTS interface and enter license key if needed. 

Engine: Choose from available options. 

Hardware: Leave default unless differently specified by vendor. 
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SR settings (Speech Recognition) 

 
Check “Enable SR” and choose available SR engine (at the time of writing this guide only Microsoft SAPI 
English SR is available, more to come). 

Enter license key if needed. 

Press “Update” button to update Speech Recognition database from PSNames.NSF. This will update the list 
of user names SR will search when caller speak a name of a person to be transferred to during autoattendant. 

See appendix C for details on installing Microsoft SAPI. 
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Answer Control settings 

 
Choose Number of rings before answer. 

Select “Perform Wink” only if using T1 lines. 

Select “Retrieve” to retrieve inband DTMF from PBX and enter Wait Time. See appendix B for details on 
PBX integration. 
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Transfer settings 

 
Choose Transfer Type: Blind (autoattendant will transfer calls to extensions without checking on extensions 
status, i.e. if an extension is busy, caller will get busy tone) or Supervised (caller will be put on hold while 
PhoneSoft checks on the status of extension; caller will be connected to extension only in case of answer). 

Check “Conference External Calls” to keep line connected in case of call transfer to external number. 

Check “Enable Call Screening” to ask caller to record his/her name before transferring to an extension. 
Recipient will be notified of incoming call from <caller> and have the opportunity to accept or send him/her 
to voice mail (note: this feature works only during autoattendant). 

Check “Enable Conv. Monitoring” to allow recipient to record phone conversation (note: this feature works 
only during autoattendant. It also require additional client software install). 

Internal/External Transfer Settings: PBX specific settings to hold/retrieve held call 

Prefix to put caller on hold: default &, 

Suffix to put caller on hold: default blank 

On Answer: to release call in case of answer during supervised call transfer: default &, 

On Busy: to return to held call in case of busy during supervised call transfer: default &, 

No Answer: to return to held call in case of no answer during supervised call transfer: default &, 

On Error: to return to held call in case of error during supervised call transfer: default &, 

Transfer Parameters 

Busy Retry: number of seconds to wait before retrying a busy extension (if hold for extension menu is 
enabled) 

Call Timeout: number of seconds after which a ringing extension is treated as no answer 
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Gateways settings 

 
If a Notes compatible fax server is installed, enable Fax Gateway and enter Notes Foreign Domain served by 
the fax server. This will allow users to forward emails by fax. 

If a Notes compatible SMS gateway is installed, enable Page Gateway and enter Page Message which will be 
sent on each voice message. 
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Message Waiting Indicator (MWI) settings 

 
Enable MWI (message lamp on telephone extensions) if you have a telephone system supporting MWI. 

Update Period: number of minutes after which the MWI refresh task will wake up and check on all users’ MWIs. Light 
will go on if at least a new voice message is found for a user. Light will go off if no new voice message is found in a 
user’s mailbox. 

Select “Use SMDI” if your PBX is connected with PhoneSoft via a serial SMDI link 

Select “Use In-Band” if your PBX uses DTMF integration. In this case also Prefix/Suffix to Set/Clear indicators is 
required. 

Select which line should be running the refresh task (usually last line) 

Select “Match Desktop” if you want light to be switched on for any unread message in mailbox (Notes desktop icon 
unread counter) 

Select “Match Inbox” for more accurate information: light will go on only if user has at least one voice message in 
inbox (Note: this might result in slow refresh for high number of users). 

MWI View: leave blank to refresh MWI for all users; enter “PhoneSoft - MWI” to refresh MWI for a limited number of 
users. 
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Modifying Unified MailCall menus and prompts 
 

All system menu choices and prompts can be modified. You can minimize user training by customizing menus and 
prompts to match up with what users are used to using.  

To modify MailCall menus 

1. In PhoneServer, click the Edit>Mailcall>Menus menus.  

2. Make changes as appropriate. 

3. After modifying a menu setting, click "Apply" and then click "OK".  

 

MailCall menus – Main Menu 

  
After the corporation's opening greeting, callers are offered a menu of options. The system administrator can redefine 
these options. By default, the following options are provided:  

Extension number  
The system will transfer a call when a caller enters a user's extension at any time during the greeting.  

0 (Operator) 
Callers can dial 0 to call the operator during most menu conversations. Any extension or phone number can be set up as 
the operator. 

• Callers with rotary phones or callers who do not dial a menu selection are also 
transferred to the operator.  

• Speech Recognition module is available, see Appendix.  

1 (Spell-by-name directory assistance) 
This option transfers calls to the directory for spelling a user's name. Directory assistance can be set up to present 
names beginning with either first or last name. Up to ten letters may be entered. The order of the name is determined by 
the Domino Directory database "Name" field.  

 

Depending on the phone system, call transfers can be set up in a variety of different ways. The phone system transfer 
settings are set up in the PhoneServer Edit>Configuration>Transfer Settings menu.  
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By default, when a call is answered by a user, the call is released. When a call is unanswered or busy, these are the 
default menu choices a caller hears: 

 

1 Leave a voice message 

Caller will hear person’s greeting and record a message which will be sent to the correct recipient. 

2 Transfer to another extension 

Caller will be able to select another extension to be transferred to. 

3 Page the user 

If a pager gateway is installed, a text message will be sent to the user. 

4 Hold until the extension is available 

The system waits for a set time, and then tries the extension again. 

0 for the operator 

Caller will be transferred to operator.  
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MailCall menus – Quick Message 

  
 

Just before recording a message to be sent to a MailCall user, caller can have alternative options: 

1 Leave Message 

Caller will hear person’s greeting and record a message which will be sent to the correct recipient. 

2 Another extension 

Caller will be able to select another extension to be transferred to. 

0 Operator 

Caller will be transferred to operator.  
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MailCall menus – Subscriber Menu 

  
 

MailCall users can log into the PhoneSoft system to access personal options. To do so caller has to press the “#” key at 
the main autoattendant menu then enter mailbox number and password. 

After having successfully logged in, caller can choose one of the following options: 

1 Review Messages 

Caller will be able to review messages in his/her Notes inbox. 

2 Access Calendar 

Caller will be able to review his/her calendar entries. 

3 Send Message 

Caller will record and send a voice message to another MailCall user.  

4 Personal Options 

Caller will access personal options (greetings, password, etc).  

 

 

 

 

 

 

 

 

 

 

 



 26

MailCall menus – Review Menu 

  
 

MailCall user can select messages to retrieve: 

1 All New Messages 

Caller will be able to review all new messages in his/her Notes inbox. 

2 New Voice Messages 

Caller will be able to review new voice messages in his/her Notes inbox. 

3 New Email Messages 

Caller will be able to review new email messages in his/her Notes inbox. 

4 New Fax Messages 

Caller will be able to review new fax messages in his/her Notes inbox (if a fax server with inbound routing is installed). 

5 By Date 

Caller will be able to review messages by date. 

6 By Subject 

Caller will be able to review messages by subject. 

7 By Originator 

Caller will be able to review messages by originator. 
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MailCall menus – Touch-Tone Entry 

  
 

Caller can accept, replay or re-enter string: 

1 Accept String 

Press 1 to accept a string. 

2 Replay String 

Press 2 to replay a string. 

3 Re-Enter String 

Press 3 to re-enter a string. 
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MailCall menus – Enable Menu 

  
 

Caller can enable or disable options: 

1 Enable Option 

Press 1 to enable option. 

2 Disable Option 

Press 2 to disable option. 
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MailCall menus – Screening Menu 

  
 

Caller can accept or reject a call: 

1 Accept Call 

Press 1 to accept call. 

2 Reject Call 

Press 2 to reject call. 
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MailCall menus – Record Menu 

  
 

Caller can save, review or re-record his/her greetings: 

1 Save 

Press 1 to save greeting. 

2 Review 

Press 2 to review greeting. 

3 Re-Record 

Press 3 to re-record greeting. 
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MailCall menus – Options Menu 

  
 

MailCall user can select between following personal options: 

1 Record Greetings 

User will be able to record personal greetings. 

2 Change Password 

User can change password. 

3 Absence Greeting 

User can enable or disable absence greeting. 

4 Paging Control 

User can enable or disable pager. 

5 Call Screening 

Caller can enable or disable call screening. 

6 Extension Control 

Caller can change his/her extension(s). 
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MailCall menus – Greetings Menu 

  
 

MailCall user can record name, greeting and absence greeting: 

1 Record Name 

User can record name. 

2 Change Password 

User can record personal greetings. 

3 Absence Greeting 

User can record absence greetings. 
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MailCall menus – Play Control 

  
 

MailCall user can rewind, pause, fast forward messages being played back: 

1 Rewind 

To rewind 3 seconds. 

1-1 to rewind to the start 

2 Pause 

Pause/Unpause. 

2 Switch Text-To-Speech language 

When multiple TTS languages are available this will allow user to switch between languages. 

3 Fast Forward 

To fast forward 3 seconds 

3-3 to fast forward to the end. 
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MailCall menus –Message Action 

  
 

MailCall user can select following actions when listening to a message: 

4 Save 

Message will be saved; system will go to next message. 

5 Replay 

Message will be replayed. 

6 Delete 

Message will be deleted. 

7 Reply 

User will reply to sender with a voice message. 

8 Forward 

Message will be forwarded (by email or fax). 

9 Envelope 

Caller will get all message details (date, etc.). 

0 Replay Options 

System will play back all Message Action menu options again. 
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MailCall menus –Forward Menu 

  
 

MailCall user can forward a message by email or fax (if a fax server is installed): 

1 Forward As Mail 

To forward as email with additional voice comment. 

2 Forward As Fax 

To forward as fax. 
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MailCall menus –Send Menu 

  
 

MailCall user chooses to send a message normal or urgent: 

1 Send Normal 

Message will be sent normal delivery. 

2 Send Urgent 

Message will be sent urgent delivery. 

 

To modify MailCall prompts 

1. Use your custom multimedia application to record prompts; rename the files to match the files that you 
are replacing. The sampling rate for recording should be 8,000 Hz, 8bit, mono. 

2. Copy the customized prompt into the \PhoneSoft\MailCall\CustomPrompts directory.  

The \PhoneSoft\MailCall\CustomPrompts directory can contain custom or site specific prompts for your application. 
When a prompt is stored in this directory it takes precedence over the file of the same name in the 
\PhoneSoft\MailCall\Prompts directory. Files in this directory are not removed during a PhoneSoft reinstall, upgrade or 
uninstall. Full list of all MailCall prompts can be found in \PhoneSoft\MailCall\Prompts\Prompts.TXT. 



 37

Setting up users 
 

Unified MailCall stores user settings information in a Domino Directory (Name and Address Book - NAB). 

Unified MailCall can use either your company's existing Domino Directory or a separate NAB. System administration 
is simpler when using the company Domino Directory. For example, when adding user names and settings, the users 
will automatically be set up to use Unified MailCall as well.  

A sample database is included with Unified MailCall (PSNames.NSF). This NAB contains the additional forms, views 
and fields required by Unified MailCall.  

To set up users in the company Domino Directory, copy these views and fields into that Domino Directory by 
performing the procedure below. To set up users in the sample NAB, see “To set up users in the sample NAB”.  

After performing one of the following two procedures, you need to set up user’s information to use voice mail and 
access their mail files over the phone.  

To set up users in the company Domino Directory 

1. Run Domino Designer.  

2. Locate and open the PhoneSoft Unified MailCall Names database (PSnames.nsf) in the PhoneSoft 
installation directory.  

3. Locate and open the company Domino Directory on the server or the replica Domino Directory in the 
\Lotus\Notes\Data directory. 

4. In the PS Names database, click "Forms" and then open the Person form for editing. 

5. Highlight and copy all of the PhoneSoft fields. 

6. Go to the company's Domino Directory or replica Domino Directory, click "Forms" and then open the 
Person form for editing. 

7. Click on a Person tab that you want to add the PhoneSoft tab after and do the following 

• Right-click and click the Insert Row menu.  

• Select the new tab, right-click and click the Table Properties Menu. In the Table Row tab, type 
PhoneSoft in the "Tab Label" box and close the Table dialog box.  

• Select the PhoneSoft tab, right-click and click the Paste menu to copy in the PhoneSoft fields.  

• Close and save the updated Person form.  

8. In the PS Names database, click "Views". 

9. Highlight and copy all of the PhoneSoft views. 

10. Go to the company's Domino Directory or replica Domino Directory, click "Views". 

11. Paste all the PhoneSoft views. 

12. Exit Domino Designer.  

13. For each user, type the appropriate information for each PhoneSoft field. For field descriptions, see the 
next procedure below. 

To set up users in the sample NAB 

1. Locate and copy the PSNames.NSF file from C:\PhoneSoft to the Lotus\Notes\Data directory on the 
Unified MailCall computer. 

2. Start Notes client and open the PSNames.NSF file, which is the sample NAB.  

3. Open your company's Domino Directory, select all users you want to add to the voice mail database. 
Copy and paste all persons documents from the Domino Directory into the sample NAB.  

4. The information required for each user allowed to call in or receive mail from Unified MailCall is 
contained in the Person Documents in the NAB. Set up the following fields for each user.  
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Users settings - Basics 

 
 

Product  
Choose between “Unified MailCall” – full Unified Messaging, “MailCall” email reader and “Script” for script 
application.  

Spelled last name  
Stores the user's last name. Automatically computes the keypad number of last names. For example, Green is 
saved as 47336.  

Canonical name  
Stores the user's full Notes canonical name and uses it for unread messages. For example, CN=Sandy 
Green/O=PhoneSoft.  
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Users settings – Mailbox Settings 

 
 

Mailbox number  
Stores user's mailbox number, extension, employee number or any other number that is unique to this user. A user 
enters this number to access his or her mailbox. 

Mailbox password  
Stores the user's password. You can set this for the user and then have the user change it later. This field is 
protected using Notes one-way encryption. 

Email address  
Stores the user's Notes mail address.  

Mail server  
Stores the mail server's name containing the user's mail file. Unified MailCall supports user mail files residing on 
different mail servers. 

Mail file  
Stores the user's mail file name and directory path. This name and path must match the user's corresponding mail 
file name and path in the mail server's database. For example, Mail\sgreen.nsf.  

View Selection  
Sets the view used for reviewing messages by phone, default is $Inbox. Make sure column values are properly set 
to retrieve messages by type, date, subject and originator. 
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Users settings – Extension Settings 

 

 

Phone Extension 
Three fields for storing three user phone system extensions or external phone numbers that Unified MailCall can 
use to contact the user. The first field value is usually the same as the "Mailbox Number" field.  
When more than one "Phone extension" field is used, Unified MailCall calls each extension, one at a time, to 
contact the user, which is also known as Call Pursuit.  
You can use the three field settings to resolve situations when different extensions are required. For example, 
when a user wants to receive calls on a cellular phone, the user can set up one of these fields to forward all calls to 
the cellular phone number.  

Enable or disable extension 
Enables or disables the use of the corresponding "Phone extension" field. 

Type 
Sets the type of call transfer to the corresponding "Phone extension" field. Settings include default, blind or 
supervised. The most common settings are supervised for external numbers and default for internal extensions.  
With the default setting, the system uses whatever the phone system is set up to do. However, Unified MailCall 
can override the phone setting with either the blind or supervised setting.  
With a blind transfer, the extension is dialed and then the call is released immediately. Because the call is 
released, the other two phone extensions are not used.  
With a supervised transfer, the call is monitored by the system and is released if the call is answered. If the called 
extension is busy or unanswered, then the system tries any other set phone extensions and then handles the call 
based on what is set up for that user. For further details, see “How the integration works” and “Call transfer”.  

Operator Mailbox 
This enables callers to be transferred to customized operator for this user. 

MWI Extension 
Default extension number for Message Waiting Indicator lamp. 

Call screening enabled 
Enables or disables call screening for a user's extension. 

Confirm deletions 
Set for users that want a confirmation message before deleting a message from their mailbox. 

Log missed calls 
Set for users that have Call screening enabled and want to receive just the call screening recording from a caller 
that leaves no message or if the call transfer failed.  
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When a user's Absence greeting is active, this field is ignored and no call screening message recordings are sent 
for these missed calls.  

Conversation monitoring 
Enables the use of conversation recording or monitoring. 

Machine name 
Store's the user's computer name for the Popup feature.  

Use MWI 
Defines if user wants Message Waiting Indicator or not.  

Announce message size 
Allows user to be notified of message size before reading.  

Review only voice messages 
This defines user to be able only to retrieve voice messages.  
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Users settings – Pager Settings 

 

 
 

Pager Enable/Disable 
Enables or disables the use of the "Pager address" field. 

Note: a Notes compatible Pager Gateway needs to be installed for this feature to take 
effect. Please contact PhoneSoft for a list of supported pager gateways. 

Pager address 
Stores the user's email address for the user's pager. See the Notes Pager Gateway Administrator's Guide for 
details. 

Numeric page string 
The dial string needed to send the numeric page. 

Page Urgent/Normal/Allow Caller 
Enables or disables corresponding feature. 
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Users settings – Voice Recordings 

 
 

Name  
Stores the user's name recording as a Wav file.  

Recorded Greeting  
Stores the user's greeting as a Wav file. For example, “I'm unavailable to take your call. Please leave me a 
message”. 

Recorded Absence Greeting 
Stores the greeting played when this greeting is enabled and the user is unavailable to answer the call. For 
example, "I'm out of the office, but will check messages in the morning". When this greeting is active, the "Log 
missed calls" field is ignored and no call screening message recordings are sent for these missed calls.  

Note: the "Do not disturb" setting that is available with some phone systems, is not 
recognized by PhoneServer. However, the user can use the Absence greeting as a "Do 
not disturb" setting for PhoneServer. 

 

To add the PhoneServer ID to the Access Control List for each user mail file 

Each voice mail user requires having the PhoneServer ID listed in his/her mail file Access Control List with 
“manager” access. This is mandatory for PhoneSoft to be able to retrieve read/unread marks and give back the 
correct list of unread messages. To do so: 

1. Open a user's mail file in Notes or Domino.  

2. Click the File>Database>Access Control menus. 

3. In the Access Control List dialog box, click "Add".  

4. Click the Person icon and then browse the Domino server to locate the Phoneserver person ID (that you 
just created in the previous procedure).  

5. Select the Phoneserver person, click "Add" and then click "OK". 

6. In the Access Control List dialog box, select the Phoneserver person and then from the Access list, click 
"Manager". Manager access is required for accurate unread message information.  

7. To allow a user to delete mailbox messages over the phone, select the "Delete documents" check box in 
the Access Control List dialog box. 

8. Repeat this procedure for each user mail file.  
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Installing RealSpeak text-to-speech (TTS) 
 

RealSpeak is an optional TTS package that provides a more natural sounding voice.  

US English is the TTS language included and installed with RealSpeak.  

To install this package, perform the procedure below.  

To install RealSpeak 

1. Confirm that the system is using the latest version of PhoneSoft software. If not, contact your sales 
representative to upgrade.  

2. Locate and double-click the Realspeak_tts_XX_vXX.exe previously downloaded from 
www.phonesoft.com  

3. When asked, type your password and click "OK". 

4. When asked, type the Unified MailCall directory path that contains the Umailcall.exe file. The default is 
C:\PhoneSoft. 

5. Follow the on-screen instructions to complete the installation. 

6. After clicking "Finish", start PhoneServer.  

7. Click the Edit>Configuration menu and then click the TTS tab.  

8. In the Interface box, click "RealSpeak".  

9. In the Key box, type the license key code and click "Upgrade". The code is sent you by email by our 
sales representatives.  

10. Confirm the appropriate number of TTS licenses is displayed above the Key box. If the wrong number 
appears, confirm that you typed the code correctly.  

11. Close the Configuration box and restart PhoneServer.  
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Installing additional text-to-speech (TTS) 
languages 
 

Unified MailCall automatically installs the US English language for you.  

In order to use other available languages or additional languages with Unified MailCall, you will need to install them 
after installing Unified MailCall. 

At the time this was published, the following are other available languages: 

• Basque 

• Chinese Cantonese 

• Chinese Mandarin 

• Danish 

• Dutch Belgian 

• Dutch Netherlands 

• English Australian 

• English British 

• English Indian 

• English U.S. 

• French 

• French Canadian 

• German 

• Italian 

• Japanese 

• Korean 

• Norwegian 

• Polish 

• Portuguese Brazilian 

• Portuguese 

• Russian 

• Spanish Castilian 

• Spanish Americas 

• Swedish 

After receiving one or more language files, perform the following two procedures to install and set up TTS languages. 

After setting up the system for multiple languages, as described see To set up Unified MailCall for multiple TTS 
languages, callers can press 2 to change to a different TTS language. The menu options will be presented in the order 
listed in the Mailcall.ini file. The "Language_x" lines define the language to be selected by pressing the corresponding 
menu numbers. The "Description_x" lines define the corresponding menu option played for each menu number. 
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To install a TTS language 

1. Download the language file from the PhoneSoft.com web site.  

2. Copy the language file to a temporary directory on the Unified MailCall computer. 

3. Locate and write down the language's password that is listed in the Readme file on the license diskette. 

4. Double-click the language file. 

5. When asked, type the appropriate password as found in step 3. 

6. When asked, type the Unified MailCall directory path that contains the Umailcall.exe file. The default is 
C:\PhoneSoft. 

7. Repeat this procedure for each language that you want to install. 

  

To set up Unified MailCall for multiple TTS languages 

1. Use a text editor to open the Mailcall.ini file.  

2. Locate the TTS Languages section in the file.  

3. Specify the default and the order in which the other languages are offered. For example, type the 
following for US English as the default and the other language options in the order listed. 

[TTS Languages] 

Language_1=ENGLISH, US 

Description_1=American English 

Language_2=ENGLISH, UK 

Description_2=The Queen's English 

Language_3=SPANISH 

Description_3=Spanish 

Language_4=LATIN AMERICAN 

Description_4=Latin American Spanish 

Language_5=GERMAN 

Description_5=Deutsch 

4. Save and close the file.  
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MailCall.INI 
The MailCall.INI file found in \PhoneSoft\MailCall carries some optional settings: 

TTS Languages Section 
[TTS Languages] 

Language_1=String Value 

Description_1=String Value 

Language_2=String Value 

Description_2=String Value 

Language_3=String Value 

Description_3=String Value 

 

See “To set up Unified MailCall for multiple TTS languages”. 

AMIS Section 
[AMIS] 

LineNum=Integer Value 

Interval=Integer Value 

AMISOutServer=String Value 

AMISOutDb=String Value 

 

See “Appendix B” for detailed explanation. 

Logging Section 
[Logging] 

LogDbServer=String Value 

LogDatabase=String Value 

 

Enable the logging feature by editing this section with appropriate information, for example: 

 

[Logging] 

LogDbServer="Srv01/PhoneSoft" 

LogDatabase="MailCallLog.nsf" 

 

Make sure MailCallLog.NSF is copied in the proper location. 

DTMF Call Progress Section 
[DTMF Call Progress] 

DTMFCP_Enabled=String Value (Y | Yes | True) 

DTMFCP_Length=Integer Value (Length of each CP string) 

DTMFCP_Answer=String Value 
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DTMFCP_NoAnswer=String Value 

DTMFCP_Busy=String Value 

DTMFCP_Ringing=String Value  

 

See “Appendix B” for detailed explanation. 

Footer Section 
 [Footer] 

Line_1=***** PhoneSoft Unified Messaging for Lotus Notes ***** 

Line_2=Quick Guide http://www.phonesoft.com/ftp/QuickGuide.pdf 

Line_3=Now you can also access your calendar and address book! 

Line_4=How to play voice messages http://www.phonesoft.com.... 

Line_5=What’s new in version 7.0 http://www.phonesoft.com/news 

 

Unified MailCall allows up to 5 lines of footer to be added at the bottom of each voice message. 

They can be used to instruct users on how to play back messages or point them to intranet sites where to retrieve 
documentation or quick reference guides. 
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TTSTranslations.TXT  

Text-To-Speech engines can be trained to read back to you in different ways than the standard way of handling text. 

For example if you company is called “Software Support Center”, you would like the TTS engine to say “Software 
Support Center” each time it encounters the string “SSC” in any piece of text being read. 

This can be achieved by editing the file TTSTranslations.TXT found in \PhoneSoft\MailCall as follows: 

  

Text Found: “SSC” 

Played As: “Software Support Center” 
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Setting up “Play by Phone” and “Play Multimedia” 
 

PSDesktop is an optional client application for PhoneSoft. With PSDesktop, users can click either the “Play by Phone” 
or “Play Multimedia” button and listen to voice messages over their phones.  

Perform the following three procedures to install and set up PSDesktop and the buttons in the Notes mail database. The 
PSDesktop buttons will then be available from the mail database's Memo Form.  

Note: if you want everyone using the Notes template database to also use the PSDesktop 
buttons, apply the procedure below to the mail template database.  

To install PSDesktop client 

1. Confirm that TCP/IP is set up on the client and the Unified MailCall computers. 

2. Locate and double-click the Setup_Psdesktop.exe file in the PhoneSoft installation directory 
(C:\PhoneSoft). 

3. Complete the PSDesktop setup wizard. 

4. Confirm that the IP network is installed correctly. You can use Chatter and Chatsvr, which are two 
Microsoft programs included with PSDesktop. 

5. From the Start menu, click Programs>Phonesoft>PSDesktop to start the utility. 

6. Select Edit>Phone Number and type the user's phone extension. 

7. Select Edit >PhoneServer Name and type the IP address or machine name of the computer running the 
voice mail system 

8. Close the program.  

  

To add "Play by phone" and "Play multimedia" buttons to a user's memo form 

1. Run Domino Designer.  

2. From Domino Designer, click the File>Database>Open menus and locate the sample mail database 
(PSMail.NSF). 

3. To open the Psmail.nsf memo form, click "Forms" and then double-click "Memo". 

4. Confirm the Action Pane window is visible in the Domino Designer window. If not, click View/Action 
and select the "Action pane" check box.  

5. In the Psmail.nsf memo form, click the "Play multimedia" action once and then click the Edit>Copy 
menus.  

6. Open user's mail file or mail template.  

7. To open the database memo form, click "Forms" and then double-click "Memo". 

8. Confirm the Action Pane window is visible.  

9. In the Action Pane window, click the last action and then click the Edit>Paste menus to paste the “Play 
multimedia" button. 

10. In the Action Pane window of the Psmail.nsf file, select the "Play by phone" action and then click the 
Edit>Copy menus.  

11. In the Action Pane window of the mail database, click the first action and then click the Edit>Paste 
menus to paste the "Play by phone" button. 

12. Save and close the mail database memo form. 

Note: If you worked on mail template database, all users' mail files will be refreshed with 
new buttons "Play by phone" and "Play multimedia". Otherwise repeat this procedure for 
all users that you want to use "Play by phone" and "Play multimedia". 
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To add the Play By Phone and Play Multimedia agents to the mail database 

1. From Domino Designer, click the File>Database>Open menus and locate the sample mail database 
(PSMail.NSF). 

2. Do the same to open the mail database for which you want to add the macros. 

3. To open the Psmail.nsf agents, click "Agents" and then click "PS Multimedia Playback". 

4. Press and hold CRTL and click "PS telephone playback". 

5. Click the Edit>Copy menus to copy both agents.  

6. Open user's mail file or mail template.  

7. To open the mail database agents, click "Agents" and then click anywhere in the Agents Pane window 
to make it the active window.  

8. Click the Edit>Paste menus to paste the agents.  

9. Confirm the agents are listed and then close and save the mail database Agents Pane window.  
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Troubleshooting read and unread messages 
 

Lotus Notes read and unread message problems can be caused by copies of the unread message lists not matching up or 
conflicting.  

A copy of the unread message list for each user is stored by Lotus Notes in three places:  

• Notes mailbox database  

• User's Desktop.dsk file 

• Notes client as an unread journal log in the Cache.dsk file 

When PhoneSoft queries a mailbox database for unread messages, Notes returns the list of unread documents from the 
database. PhoneSoft then arranges and presents the unread messages to the user. The number of unread messages when 
calling from the phone should be the same as the number of unread messages viewed in the mailbox from the Notes 
client or browser on any computer.  

Canonical name problem 
Lotus Notes uses the User's Canonical Name to track unread messages. The "Canonical Name" field is located in the 
PhoneSoft section of the Domino Directory. 

If this field is incorrectly set up in the NAB, the user receives a different number of unread messages from the phone, 
as compared to the Notes desktop.  

To find the "Canonical Name" field value 

1. Open the user’s mail file.  

2. Find a document created by that user, highlight and right-click the document.  

3. Select the Document Properties menu.  

4. Click the Fields tab.  

5. In the "From" field list, locate the correct Canonical Name as shown on the bottom right of the window 
(example: CN=Sandy Green/O=Your Company).  

6. Highlight, copy, and paste this Canonical Name into the Unified MailCall NAB "Canonical name" field. 
(Do not copy the quotes.) 

Mail file open conflict 
When user mail files are open on their desktops and they check messages over the phone, the read and unread message 
information can be inaccurate. The inaccuracy is caused by Notes updating the database copy of the unread list only 
when user mail files are closed on the desktop. This situation is resolved by Notes when users close their mail files.  

Access Control List problem 
Notes requires that the Notes ID for the Unified MailCall computer have the Manager access level to user mail files. 
Without Manager Access, users are unable to receive read and unread message information and a corresponding error 
appears in the PhoneServer log when users try to check unread messages. See To create a PhoneServer Notes ID for the 
Unified MailCall computer.  

View problems 
By default, Unified MailCall searches for and reads messages from the Notes ($Inbox) folder. To create a custom view, 
you can create a view named $PS Review. When the $PSReview view exists in user mailboxes, Unified MailCall 
automatically uses that view instead of the $Inbox view for reviewing all phone based messages.  

For Unified MailCall to successfully use the $PS Review view, specific column positions are mandatory. See the 
sample database, the Psmail.nsf file, for column positions.  
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When Unified MailCall uses a specific view ($Inbox or $PS Review) for message review, only unread messages in that 
view are seen by Unified MailCall. 

Replica database problems 
When using replica database files with Unified MailCall and Notes, users can get confused by inaccurate read and 
unread message information. Unread message information does replicates between database replicas; however it is not 
always immediate. So when users check unread messages both by phone and desktop close to the same time, the 
message counts can be inaccurate, because replication has not yet occurred.   

Notes servers earlier than version 4.5 
With this older software, an error message appears in the PhoneServer log that an unsupported function was attempted 
when users try to check unread messages with Unified MailCall. 

Notes server software that is earlier than version 4.5 lacks support for accessing unread message information from a 
Notes server. Earlier versions only support API access to unread message information in local databases.  

To resolve this lack of support, leave the "Notes Server" field blank, and type in a network mapped path (such as 
Z:\Notes\Data\Mail) to each user's mail file as if the file were local.  

Notes limitations 
Lotus has solutions for unread message problems documented in the Lotus Notes Knowledge Base. For details, see: 

• Document 169936, "Are unread marks fixed in release 5?" 

• Document 160731, "How do unread marks work in a Notes/Domino 4.x environment?" 

• Document 179683, "Two common unread mark scenarios: new mail appears read and already opened 
mail appears unread" 

Minimizing problems 
You can minimize or often eliminate the problems described in this section. Do one or more of the following to resolve 
the most common problems:  

• Confirm that users always access the same mail file replica as Unified MailCall. If users access 
different replicas, unread message information may be inaccurate.  

• If one of the replicas is a local replica (on a client), use the "Replicator_sync_unread=-1" setting in 
the Notes.ini file on that client. Doing so forces unread synchronization during each replication and 
minimizes errors.  

• Access all replicas frequently. If users wait long periods of time between accessing a given replica, 
older unread entries in the Notes journal file may be overwritten and lost before replayed to other replicas.  

• Avoid using the "Mark all read" or "Mark all unread" settings when using very large mail files 
(over 1,000 documents) with multiple replicas, because the Notes journal file does not track these unread 
changes to other replicas.  

• When using multiple replicas, use the Notes R5 Workspace page to unstack replica icons. Select 
two of the replicas and force replication of the unread tables by clicking the Edit>Unread Marks>Exchange 
Unread Marks menus. This sets up a manual process, but is more powerful than the 
"Replicator_sync_unread=-1" setting, because it allows unread replication between multiple server based 
replicas.  
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Appendix A – Intel Dialogic voice boards 
 
 
 Intel Dialogic D/4PCI analog voice board 55 
   
 Intel Dialogic D/42JCT and D/82JCT digital PBX voice board 57 
   
 Intel Dialogic D/120JCT analog voice board 59 
   
 Intel Dialogic D/240JCT and D/480JCT digital T1 voice board 61 
   
 Intel Dialogic D/300JCT and D/600JCT digital E1 voice board 62 
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Dialogic D/4PCI analog voice board 
 
 

 

Capacity 
4 ports, analog lines. 

Connection Pinouts 
The D4/PCI board uses RJ-14 connectors. 

 

P in 1: Unused

Pin 2: Firs t po rt tip

Pin  3 : F ir st port ring

Pin 4: Unused
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Hardware settings 
Do the following procedures as you install voice boards. 

To set switch SW30 and SW4 

The system software assigns board instance numbers in ascending order (beginning with 0) as it detects each board in 
your system. A board instance number is the identification (ID) number used by the system software to recognize the 
board. Each board ID is based on the SW30 rotary switch setting. 

Set rotary switch SW30 to a unique number for each installed board (default 0). 

First PCI board 
1

 

Second PCI board 
2

 

Third PCI board 
3

 

To set switch block SW2 

The position of the slide switch SW4 determines how the board responds to an incoming call when the chassis power is 
on but the board is not initialized. 

Set slide switch SW4 as follows: 

• SW4 = On-hook (default): callers hear ringing. 

• SW4 = Off-hook: callers hear busy signal.  

Note: if the chassis power is off, callers hear ringing (on-hook). 
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Dialogic D/42JCT and D/82JCT digital PBX voice 
boards 

 
 

 

 
 

Capacity 
4 and 8 ports, digital PBX lines. 

Connection Pinouts 
The D42/JCT and D/82JCT boards use a 36-position mini D cable plug and D connector which in turn plugs into an 
industry standard breakout box (RJ-11 connectors). The above diagram shows the alternative development cable which 
terminates with RJ-11 connectors. 
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Hardware settings 
Perform the following procedures as you install voice boards. 

To set the PBX mode1 

Use the Intel Configuration Manager (DCM) to specify the exact model of PBX you are connecting. Supported PBX 
models are: 

PBX Manufacturer Phone Emulations Switches 

Avaya 7434 (4-wire) 
DEFINITY 
System 75/85 

Avaya 8434 (2-wire) DEFINITY (G3 V4 and higher) 

Mitel Superset 420 SX-50 

Mitel Superset 430 
SX-200ML 
SX-2000 

NEC DTERM111 
NEAX 2400 
NEAX 2000 IVS, IVS2, IPS 
Electra Elite, Professional 

Nortel Networks M2616 Meridian 1 

Nortel Networks M7324 Norstar DR5, CICS, MICS 

Siemens Optiset E Hicom 150, 300 

Siemens ROLMPhone 400 CBX 9005, 9006, 9751 
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Dialogic D/120JCT analog voice board 

 

 

Capacity 
12 ports, analog lines. 

Connection Pinouts 
The D120/JCT board uses 6 RJ-14 connectors. 

 

 
 

Pin 1: 2nd port tip 
Pin 2: 1st port tip 
Pin 3: 1st port ring 
Pin 4: 2nd port ring 
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Hardware settings 
Perform the following procedures as you install voice boards. 

To set switch SW100 and SW1 

The system software assigns board instance numbers in ascending order (beginning with 0) as it detects each board in 
your system. A board instance number is the identification (ID) number used by the system software to recognize the 
board. Each board ID is based on the SW100 rotary switch setting. 

Set rotary switch SW100 to a unique number for each installed board (default 0). 

First PCI board 
1

 

Second PCI board 
2

 

Third PCI board 
3

 

The position of the slide switch SW1 determines how the board responds to an incoming call when the chassis power is 
on but the board is not initialized. 

Set slide switch SW1 as follows: 

• SW1 = On-hook (default): callers hear ringing. 

• SW1 = Off-hook: callers hear busy signal.  

NOTE: if the chassis power is off, callers hear ringing (on-hook). 
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Dialogic D/240JCT and D/480JCT digital T1 voice 
boards 

 

Capacity 
24 and 48 ports, digital lines. 

Connectors 
The D/240JCT, D/480JCT boards use BNC for 75 Ohm lines or RJ-48C for 120 Ohm lines. 

Hardware settings 
Perform the following procedures as you install voice boards. 

To set switch SW100 

The system software assigns board instance numbers in ascending order (beginning with 0) as it detects each board in 
your system. A board instance number is the identification (ID) number used by the system software to recognize the 
board. Each board ID is based on the SW100 rotary switch setting. 

Set rotary switch SW100 to a unique number for each installed board (default 0). 

First PCI board 
1

 

Second PCI board 
2

 

Third PCI board 
3
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Dialogic D/300JCT and D/600JCT digital E1 voice 
boards 

 

Capacity 
30 and 60 ports, digital lines. 

Connectors 
The D/300JCT, D/600JCT boards use BNC for 75 Ohm lines or RJ-48C for 120 Ohm lines. 

Hardware settings 
Perform the following procedures as you install voice boards. 

To set switch SW100 

The system software assigns board instance numbers in ascending order (beginning with 0) as it detects each board in 
your system. A board instance number is the identification (ID) number used by the system software to recognize the 
board. Each board ID is based on the SW100 rotary switch setting. 

Set rotary switch SW100 to a unique number for each installed board (default 0). 

First PCI board 
1

 

Second PCI board 
2

 

Third PCI board 
3
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DID environment 
 

A typical DID environment is where all extension can be reached directly from the outside world by their own 
extension numbers. For example the company main number is 123-456-7777 and all employees’ extensions are from 
123-456-7000 to 123-456-7999 (except 7777).  

If employees’ extensions can be reached directly from outside they can be diverted to the PhoneSoft system in case of 
extension busy or not answering after few rings (or seconds). 

This configuration is programmed on the telephone system (PBX), so that, for example if you called 123-456-7890 and 
that extension is busy, the call gets automatically diverted to the PhoneSoft hunt group number being for example 7999. 

PhoneSoft will then receive the 4 digits extension from the PBX and process incoming call answering with the correct 
person’s greeting of extension 7890. 

In this particular case PhoneSoft has to be configured to retrieve the “inband” DTMF digits by going off-hook and 
waiting a certain amount of time to allow digits to come through, for example 1,500 milliseconds. 

 
 

In this way PhoneSoft will always wait one and half seconds at the very start of each call for the inband information to 
arrive. If a valid extension is received PhoneSoft will answer with the correct person’s greeting, otherwise the default 
main menu prompt will be played. 
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Auto-attendant environment 
An auto-attendant environment is where all incoming calls are received and handled by PhoneSoft. 

Extensions cannot be reached from the outside world and the only way to reach them is through the auto-attendant 
menus. 

In this case PhoneSoft will always ask the caller the desired extension before attempting to transfer. 

In case nobody can take the call on the extension required, PhoneSoft will play back the person’s greeting and allow 
caller to leave a message 

Two different types of call transfer can be used, supervised and blind.  

Supervised Call Transfer 

In a supervised call transfer PhoneSoft puts the caller on hold while attempting to transfer the call to the required 
extension. If PBX provides music on hold, caller will hear music from the phone system. 

 
 

To perform a supervised call transfer, PhoneSoft does a “flash hook” (“&” sign). If the flash hook duration is correct 
for your PBX, caller will be put on hold, resulting in music being played on caller. PhoneSoft will then attempt to dial 
the desired extension and do one of the following depending on result of that call: in case of answer it will connect 
calling and called party and release the line, revert to the caller in case of extension busy or not answering. 

Flash hook duration can be adjusted to the value required by your PBX by editing the Vvoice32.INI file located in the 
Windows directory. 

The FLASHTM variable defines the hook flash duration, its default value is 50 (100th second), half second. 
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Blind Call Transfer 

In a blind call transfer PhoneSoft simply puts a caller on hold just for the time needed to dial the extension required, the 
line is then cleared and goes back waiting for next call. The call handling is left in the hands of the PBX system without 
any verification as whether the required extension is busy or does not answer. 
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Hang-up detection 
On US domestic phone systems hang-up is sent by the PBX using a loop current drop. 

The Dialogic drivers automatically detect the loop current drop and pass the hang-up information onto the application 
which ends the call, clears the line and goes back waiting for call. 

Hang-up tone 

On non-domestic PBX systems, instead of loop current drop, a hang-up tone is sent on the line. 

In this case Dialogic drivers cannot recognize the hang-up automatically therefore an additional setting is required to 
recognize the hang-up tone. Typically a hang-up tone is a single or dual frequency tone, continuous or cadenced, for 
example: 

a) 350/440Hz, 0,35 seconds ON, 0,35 seconds OFF 

b) 400Hz, continuous 

Once again a value in VVoice32.INI file located in the Windows directory can help PhoneSoft to recognize a hang-up 
tone: 

T5=350,20,440,20,35,2,35,2,2 (Freq1=350+/-20, Freq2=440+/-20, on=(35+/-2)/100sec, off (35+/-2)/100sec) 

or 

T5=400,20,0,0,0 (Freq1=400+/-20, continuous) 

When a tone with that frequency and cadence is detected, PhoneSoft detects caller hang-up and clear the line, going 
back waiting for call. 

 

Hang-up DTMF tone 

Also hang-up can sometimes be notified with a DTMF tone instead of usual hang-up tone or loop current drop. To 
enable a DTMF tone (or string of tones) to be recognized as hang-up: 

1. From the Start menu, choose the Run menu. 

2. Type regedit and click "OK". 

3. Go to HKEY_LOCAL_MACHINE->Software->PhoneSoft->PhoneServer. 

4. Edit the string HANGUPDIGITS as needed. 
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Complex inband DTMF integration 
Some phone systems such as Siemens Hicom 300, Philips Sopho, Alcatel 4400, etc. can be configured to pass onto the 
voice mail analog extensions additional call information in the inband DTMF string mentioned in the previous 
paragraph “DID environment”. 

A complex DTMF string carrying full call information such as call type (direct, diverted on busy, diverted on no 
answer, diverted all – do not disturb), calling party and called party is sent by the PBX and received by the PhoneSoft 
system. 

For example an internal call from extension 1234 to extension 5678 diverted to voice mail might result in the following 
string being received: ****1234**5678. 

Obviously PhoneSoft by default is not able to handle that complex string and therefore requires some call pre-
processing before taking the correct action. 

To do that we use the PhoneSoft SDK which allows any Lotus Notes developer to build custom voice application to 
access any Notes database to perform any sort of action a Notes client would allow: search, create, delete documents, 
read or write fields, attach voice recording to a document, run LotusScript agents. 

Please refer to the PhoneSoft SDK Manual for a comprehensive list of features and examples. 

Using the PhoneSoft Script editor, create a script called ParseDigits.PSS 

 
 

This script will first of all wait for two seconds and retrieve the full string of digits from the PBX. 

It will then pass the whole string of digits to a LotusScript agent 
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This agent, called ParseDigits, stored in PSNames.NSF, will receive the inband string and parse the calling and called 
numbers. It will also search the caller’s name if calling number is found in PSNames.NSF. 

 

 
… 

Set Session =New NotesSession 

Set Document = Session.DocumentContext 

InbandDigits = Document.GetItemValue (“InbandDigits”) (0) 

Parse CallingParty, CalledParty and CallType 

… 

If CallType = DivertedCall Then 
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Set Database = Session.CurrentDatabase 

Set MailboxView = Database.GetView (“PS By MailBox”) 

Set ExtensionDocument = MailboxView.GetDocumentByKey (CallingParty, True) 

If (ExtensionDocument Is Nothing) Then 

  Document.CallerName = CallingParty 

Document.Action = "Leave Msg" 

Document.Extension = CalledParty 

  Exit Sub 

End If 

Document.Action = "Leave Msg" 

Document.CallerName = ExtensionDocument.GetItemValue (“FullName”) (0) + " on " + CallingParty 

Document.Extension = CalledParty 

Else … 

Some variables (Action, CallerName, Extension) will be returned back to the ParseDigits.PSS script, which will take 
appropriate action based on the type of call: leave a message to “Extension” from “CallerName” in case of action 
“Leave Message”, user login in case of direct call from internal extension, play default Unified MailCall main menu in 
case of direct call from outside. 

 
 

Just before leaving a message we can overwrite the CALLER_ID system variable so that the full caller name can be 
placed in the voice message subject: 
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Enable ParseDigits.PSS in PhoneServer menu >Edit>MailCall>Script…  
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Calista SMDI Integration 
Certain phone systems such as Mitel, Siemens, Avaya, and Nortel might require some third party hardware to integrate 
PhoneSoft when using analog telephone lines. 

Please note: this section of the present Administrator Manual is now obsolete since Unified MailCall version 7 
supports D42/D82 digital boards which can be used with phone systems listed above. 

The Calista integration unit provides call information for phone systems which do not give (or give poor) inband 
DTMF info. The call information is sent through a serial link which connects the Calista unit to the PhoneSoft PC. 

Configure PhoneServer to use the SMDI link on the correct COM port: 

 
 

Once SMDI is enabled, PhoneSoft will work seamlessly, although you could still use PhoneSoft SDK and LotusScript 
to generate the caller name to place in the voice messages’ subjects (see paragraph “Complex Inband DTMF 
integration”). 
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Other SMDI Integrations 
 

Some phone systems such as Ericsson MD110, NEC 2000, Nortel DMS100, NEAX 2400 and Cisco Call Manager 
support serial integration to provide call information on analog lines. 

The call information is sent through a serial link which connects the PBX system to the PhoneSoft PC. 

Configure PhoneServer to use the SMDI link on the correct COM port: 

 
 

Once SMDI is enabled, PhoneSoft will work seamlessly, although you could still use PhoneSoft SDK and LotusScript 
to generate the caller name to place in the voice messages’ subjects (see paragraph “Complex Inband DTMF 
integration”). 
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DTMF Call Progress  
 

Certain phone systems use DTMF Call Progress as a way of integrating with voice mail systems. 

The PBX sends to Unified MailCall DTMF tones to communicate particular lines statuses. For example if the line goes 
off-hook, a tone is sent instead of the usual dial tone. If caller hangs up a tone is sent instead of the usual hang-up tone 
(or loop current drop). 

Unified MailCall can be configured to recognize the DTMF tones sent by the PBX by mean of a specific section in the 
MailCall.INI file, see below: 

 

[DTMF Call Progress] 

DTMFCP_Enabled=Yes  

DTMFCP_Length=1  

DTMFCP_Answer=a  

DTMFCP_NoAnswer=1  

DTMFCP_Busy=b  

DTMFCP_Ringing=d 

 

In this example DTMF Call Progress has been enabled with a PBX sending one single digit (length = 1). On answer 
PBX will send DTMF tone “a”, on busy PBX will send “b” (Note: other than usual DTMF tones “1” to “9”, “*” and 
“#” also “a”, “b”, “c” and “d” can be generated and detected). 

 

Hang-up DTMF tone definition 

As you can notice, the hang-up DTMF tone definition is not present in the MailCall.INI section. 

To enable a DTMF tone (or string of tones) to be recognized as hang-up: 

1. From the Start menu, choose the Run menu. 

2. Type regedit and click "OK". 

3. Go to HKEY_LOCAL_MACHINE->Software->PhoneSoft->PhoneServer. 

4. Edit the string HANGUPDIGITS as needed. 
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Digital integration D/42JCT and D/82JCT 
 

PhoneSoft supports digital integration with phone systems such as Avaya, Mitel, NEC, Nortel and Siemens using 
digital set extensions. Specific Dialogic D/42JCT and D/82JCT boards have to be used to emulate digital phone sets. 
The emulation of the digital set display gives the call information to the Unified MailCall application. 

Configure the board in the Dialogic Configuration Manager to connect to your PBX model 

 
 

You must use PhoneSoft SDK and LotusScript to parse the information and obtain calling party, called party and 
generate the caller name to place in the voice messages’ subjects (see paragraph “Complex Inband DTMF integration”). 

To enable the display retrieval on D/42JCT and D/82JCT boards, edit the variable D42Line in Vvoice32.INI located in 
the Windows directory as follows: 

 
PBX Manufacturer Switches Phone Emulations VVoice32.INI 

Avaya DEFINITY (G3 V4 and higher) 8434 (2-wire) D42Line=1 

Avaya 
DEFINITY 
System 75/85 

7434 (4-wire) D42Line=2 

Mitel SX-50 Superset 420 D42Line=3 

Mitel 
SX-200ML 
SX-2000 

Superset 430 D42Line=4 

NEC 
NEAX 2400 
NEAX 2000 IVS, IVS2, IPS 
Electra Elite, Professional 

DTERM111 D42Line=5 

Nortel Networks Meridian 1 M2616 D42Line=6 

Nortel Networks Norstar DR5, CICS, MICS M7324 D42Line=7 

Siemens Hicom 150, 300 Optiset E D42Line=8 



 77

Siemens CBX 9005, 9006, 9751 ROLMPhone 400 D42Line=9 
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Digital integration D/240JCT-T1 and D/300JCT-E1 
 

PhoneSoft supports digital T1 and E1 lines with any phone system or carrier.  

T1 integration 

Robbed-bit (24 channels) and ISDN (23 channels) are supported on North American 1.5 Mbit T1 trunks.  

T1 integration – Robbed-bit 

For Robbed-bit configure the board not to use any ISDN protocol: 
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Configure PhoneServer to use “Wink start” if your telephone system or carrier requires that before sending inband 
DTMF call information. 

 
 

Set PhoneLineType=1 in Vvoice32.INI file located in the Windows directory. 

You can use PhoneSoft SDK and LotusScript to parse the information and obtain calling party, called party and 
generate the caller name to place in the voice messages’ subjects (see paragraph “Complex Inband DTMF integration”). 
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T1 integration – ISDN 

For ISDN configure the board to use your preferred ISDN protocol: 
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Also the ParameterFile value should mach the protocol: 

 
 

Set PhoneLineType=3 in Vvoice32.INI file located in the Windows directory. 

You can use PhoneSoft SDK and LotusScript to parse the information and obtain calling party, called party and 
generate the caller name to place in the voice messages’ subjects (see paragraph “Complex Inband DTMF integration”). 
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E1 integration 

ISDN (30 channels) is supported on international 2Mbit E1 trunks. 

For ISDN configure the board to use your preferred ISDN protocol: 
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Also the ParameterFile value should mach the protocol: 

 
Set PhoneLineType=3 in Vvoice32.INI file located in the Windows directory. 

You can use PhoneSoft SDK and LotusScript to parse the information and obtain calling party, called party and 
generate the caller name to place in the voice messages’ subjects (see paragraph “Complex Inband DTMF integration”). 
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AMIS Integration 
 
AMIS (Analog Messaging Interface Specification) is used to connect and exchange voice messages with other Voice 
Mail systems AMIS compatible. 
 
To enable a user on a third-party Voice Mail system to receive messages left for him on the PhoneSoft system follows 
these steps: 
 
1) Create a mail-in database, for example 
 
Name: AMISMail 
Server: Srv01/PhoneSoft 
File name: AMISMail.NSF 
 
2) For each AMIS user in the PhoneSoft Address Book (PSNames.NSF) specify 
 
E-mail Address: AMISMail 
System Number: <hunt group of the other voice mail system> 
Receiver Mailbox: <mailbox on the other voice mail system> 
 
3) Edit or create MailCall.INI file in C:\PhoneSoft\MailCall 

 

[AMIS] 

LineNum=1;this is the line that will connect the other voice mail system and exchange voice messages 

Interval=1;time interval in minutes 

AMISOutServer=”Srv01/PhoneSoft” 

AMISOutDb=”AMISMail.NSF” 
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Setting up SAPI text-to-speech (English, French, German only) 
PhoneSoft supports Microsoft SAPI Text-To-Speech for a limited number of languages, which come free with the 
Windows operating system or can be downloaded for free from www.microsoft.com. 

Enable PhoneServer to use the SAPI engine: 
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Make sure SAPI TTS is available in your Windows installation and select the language you want from the Control 
Panel Speech applet: 

 
For French and German SAPI engines you might need to download additional setup files from www.microsoft.com. 
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Setting up SAPI Speech Recognition (English only) 
PhoneSoft supports Microsoft SAPI Speech Recognition for the English language, which comes free with the Windows 
operating system or can be downloaded for free from www.microsoft.com. 

Enable PhoneServer to use Speech Recognition: 

 
 

Press the “Update” button to update the speech recognition database of names from the PhoneSoft address book. 

Make sure SAPI Speech Recognition is available in your Windows installation from the Control Panel Speech applet: 

 
 

You might need to download setup files from www.microsoft.com. 
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What is the Address Book Access module 
PhoneSoft provides a script application to access the users’ address books provided these are located on a Domino 
server. 

This script is provided to customers as part of the default deliverable as a sample of a complex script application 
developed with the PhoneSoft SDK scripting tool, as well as to put it quickly in production with no effort at all! 
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Objective of the application 

The objective of the script is, as the title says, to access a user’s address book and search a person by first and last 
name. Once the correct person is found, the system can: 

• retrieve phone/fax numbers, email address, business address 

• send a voice message to the person’s email address 

• fax the person record to a remote (hotel) fax machine 

The PhoneSoft script application, called AddressBookAccessDemo.PSS, makes use of few LotusScript agents stored in 
the PhoneSoft address book (PSNames.NSF) to achieve sophisticated Notes functionalities by the use of any standard 
phone. The main agent is “(PS Search Person)” which is used to retrieve a person document by first name and last 
name. 
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Main points 

 

Let’s see what the main points of the script are 

Application setup 

That’s the starting point of the script: few variables are set according with the local environment 

 
sNamesServer and sNamesDB: location of the PhoneSoft address book. 

sMailboxServer: MAIL.BOX router mailbox location (typically your Domino mail server). 

sDirServer and sDirDB: fall-back/common address book to search. 

sGateway: foreign domain gateway served by your fax server (if available). 

User authentication 

The first thing the script does is to authenticate the caller, for security reasons and to access the correct address book 
database. 



 93

 

A prompt asks the caller to enter mailbox number, a maximum of 10 digits are accepted for a timeout period of 20 
seconds. 

User information retrieval 

System searches for user’s mailbox. 
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If a valid document is found all relevant information is retrieved. 
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System asks user’s password …. 

 
… and authenticates user by mean of the agent “(PS Compute Password)” which receives the digits password and 
encrypts it before comparing against the user’s password. 
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Document.PSPassword = Evaluate (| @Password (Password) |, Document) 

Contact information retrieval 

Finally system asks user to enter last name and first name to search for. 

 
 

Note: last name and first name are entered as digits mapped on the telephone keypad. 

 
To enter Smith, caller should enter 76484, or at least the first letters (764…). 

To enter John, caller should enter 5646 (or 56…). 

The two strings of digits will be passed then onto the “(PS Search Person)” agent for the final search. 
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… 

sLName =  Document.LastName(0) 

sFName =  Document.FirstName(0) 

sServer =  Document.Server(0) 

sDatabase = Document.Database(0) 

 

keys( 1 ) = sLName 

keys( 2 ) = sFName 

 

' Open database 

Call Database.Open( sServer, sDatabase ) 

If Not Database.IsOpen Then 

 Document.PersDocID = "" 

 Exit Sub 

End If 

 

' Open view 

Set PersonView = Database.GetView( "SpelledName" ) 

If ( PersonView Is Nothing ) Then 

 Document.PersDocID = "" 

 Database.Close 
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 Exit Sub 

End If 

 

' Search document by key 

Set PersonDocument = PersonView.GetDocumentByKey( keys, False ) 

If ( PersonDocument Is Nothing ) Then 

 ' No document found 

 Document.PersDocID = "" 

Else   

 ' Found the document, return the NoteID 

 ' but before I have to convert it from hexadecimal to integer 

 Document.PersDocID = Cint("&H" & PersonDocument.Noteid) 

End If 

… 

Note: since the search is performed based on strings of digits, contacts’ last name and first name are to be converted 
into their digits corresponding by a formula 

T1 := @Left(@UpperCase(LastName ); 12); 

T2 := @Implode(@Replace(@Trim(@Middle(T1; 0; 1) : @Middle(T1; 1; 1) : @Middle(T1; 2; 1) : @Middle(T1; 3; 1) 
: @Middle(T1; 4; 1) : @Middle(T1; 5; 1) : @Middle(T1; 6; 1) : @Middle(T1; 7; 1) : @Middle(T1; 8; 1) : 
@Middle(T1; 9; 1) : @Middle(T1; 10; 1) : @Middle(T1; 11; 1)); "A" : "B" : "C" : "D" : "E" : "F" : "G" : "H" : "I" : "J" 
: "K" : "L" : "M" : "N" : "O" : "P" : "Q" : "R" : "S" : "T" : "U" : "V" : "W" : "X" : "Y" : "Z" ; "2" : "2" : "2" : "3" : "3" : 
"3" : "4" : "4" : "4" : "5" : "5" : "5" : "6" : "6" : "6" : "7" : "7" : "7" : "7" : "8" : "8" : "8" : "9" : "9" : "9" : "9" )); 

@Trim(@Middle(T2; 0; 1) + @Middle(T2; 2; 1) + @Middle(T2; 4; 1) + @Middle(T2; 6; 1) + @Middle(T2; 8; 1) + 
@Middle(T2; 10; 1) + @Middle(T2; 12; 1) + @Middle(T2; 14; 1) + @Middle(T2; 16; 1) + @Middle(T2; 18; 1) + 
@Middle(T2; 20; 1) + @Middle(T2; 22; 1)) 

New spelled fields will then generate the view to search through… 

 

Contact information management 

Now system has found the person the user is looking for, all record information can be used: 
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Read back the office telephone number and even call it 
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Read the business address 

 

Fax the person record to a remote (hotel) fax machine 
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Send a voice message to the email address 
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Roll it out! 
You can roll this script out (it’s free of charge!), by following the suggestions below. 

The PhoneSoft system can be used as normal (Auto-attendant, Voice Mail, Unified Messaging) and fire up the Address 
Book Access script whilst accepting and processing phone calls. 

You can have a dedicated virtual extension diverted to the PhoneSoft system or just have an access code for it: just 
create a document in the PhoneSoft address book (PSNames.NSF) as below: 

 
In this way mailbox 888 will fire up the Address Book Access application. 

By default the application will access the address book specified in the script application setup document, but each user 
can have his/her own address book replicated on a server that is accessible by this application. The Personal Address 
Book Information fields are used to that purpose. 
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Further enhancements 
The Address Book Access application is obviously open to custom development. 

It is provided as a sample although it can be easily used in production. 

If you have custom databases such as CRM databases you want to access and search by phone you can use the Address 
Book Access application as a starting point to develop your first Computer Telephony Application for Lotus Notes and 
Domino! 


